Page 1 of 1

ModbusTCP

Posted: Tue Jan 24, 2017 7:09 am
by RickTCP
I am trying to create a small test screen displaying numeric data on a gauge through ModbusTCP.
I am starting out with Winlog Lite demo and will upgrade once I see a single parameter working.

I have a Brainchild HMI panel reading a voltage analogue input and serving the value as a ModbusTCP variable. I have addressed it as 400001.
I have confirmed using another demo software that the ModbusTCP values are available.

I have not yet seen any values display in Runtime.

Can I leave a template open in Runtime and go into Project Manager to make changes?
Will the changes show without restarting Runtime?

I am running out of things to try in setting up the Gate.
Any thoughts please?

Thank you

Re: ModbusTCP

Posted: Tue Jan 24, 2017 8:21 am
by admin
Dear Sir,
normally 400001 address is in "holding register" table. For reading holding register you must use the function "3" (see help) in Winlog; then in Gate Builder you have to insert address 3:0001 or 3:0000 (depending on your device's mapping, try both).

Can I leave a template open in Runtime and go into Project Manager to make changes?
Will the changes show without restarting Runtime?


No, for gate and protocol you have to restart Runtime.

If it doesn't work please send you test application, we check it.

Best regards

Re: ModbusTCP

Posted: Tue Jan 24, 2017 10:28 pm
by RickTCP
Thank you

I will work through it and report back.

Regards
Rick

Re: ModbusTCP

Posted: Wed Jan 25, 2017 12:40 am
by RickTCP
Thank you

3:0 worked to read the 400001 address I had setup to serve from the HMI Panel.

Regards
Rick